Xdebug and Netbeans


#1

Hi,
I’m currently testing Local on windows and I have been quite impressed so far how easy is the setup.
I have been wondering if anybody has used NetBeans and Xdebug together with Local.
I think I got the xDebug config right but still it doesn’t seem to work.

[Xdebug]
zend_extension = /opt/php/7.0.3/lib/php/extensions/no-debug-non-zts-20151012/xdebug.so
xdebug.remote_enable=1
xdebug.remote_connect_back=On
xdebug.remote_port=“9000”
xdebug.profiler_enable=0
xdebug.remote_host=102.168.94.1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_autostart=true
xdebug.idekey=“netbeans-xdebug”

I was hoping someone got it working and could offer some pointers.

Thanks

Michael


#2

Working for me, must set project>>properties>>sources correctly for netbeans to step through code correctly.

I also set netbeans>>preferences>>php>>debugging>>session-ID to “www-data” instead of changing php.ini

[Xdebug]
zend_extension = /opt/php/7.0.3/lib/php/extensions/no-debug-non-zts-20151012/xdebug.so
xdebug.remote_enable=1
xdebug.remote_connect_back=On
xdebug.remote_port="9000"
xdebug.profiler_enable=0


#3

Hello Keith,

I’m having issues with xdebug on Netbeans and I think you can help me some the issue. I can debug the debug line is not highlighted which means I can’t see where the debug cursor is.

I’ve read some messages that pointed to the project>>properties>>sources not being set correctly.

Could you share your settings with me? I now have the local plugin folder (like D:\LocalWebsites\DevelopmentWebsite\app\public\wp-content\plugins\myplugin) in the Source Folder and “” in my Web Root.

As far as I can see I can’t set the Web Root differently, but I was wandering what your settings are.

Best regards,
Michel


#4

I too had same problem. Solution is to browse to the web root in project settings.