Very slow on Windows 10

performance

#1

Hi there

I’m using LbF in order to develop my site in a local mode ; I guess LBF is done for that.

Unfortunately, it’s very slow :

  • opening LbF takes almost 1 mn (dedicated to “starting local machine”)

  • changing page takes about 5 to 15 seconds

I’m now on 2.4.2; I’ve had the same issues with previous versions.

I’m on Windows 10 + Firefox

No other applications running

With or without Avast is the same

With or without active Internet connection is the same

Faster Dockers Vol. seems unstable : “local has succesfully disable F.D.V.” ; when stable, LbF isn’t quicker

IP6V Loopback is stable but doesn’t seem to have an effect on speed.

I’ve been looking through your forum but didn’t find anything for me

Can you help me ?

Thanks

Romain


#2

I have the same problem, it’s impossible for me to work like this so I had to spin up a VPS on DigitalOcean because it’s like 20x faster. Each page load takes between 20s and 60s which is a nightmare during development.

I’ve applied every single potential fix that I’ve found in the forums but nothing helps. If I disable all the plugins it works fine, and you might say that it’s a plugin causing the problem, but why doesn’t it cause it on the live environment too? I’ve tried with no internet, installed the Airplane Mode plugin, nothing helps. It happens with many different sites, as long as they have more than 10/15 plugins enabled.

Why doesn’t this happen with DesktopServer? I can load ultra-bloated sites at the same speed of a live environment. I have an i7 with 16GB RAM, tried to give as much power to the VirtualBox as possible, increase PHP memory, really nothing helps. What gives?


#3

As for me, there’s just one plugin enabled (Woocommerce)
but it keeps that slow ever


#4

I also have WooCommerce installed on the site I’m currently working on, it could be the culprit but I sure as hell can’t work on it if I disable it.

I would love for the devs to seriously acknowledge there’s something really wrong with Local’s speed on W10 machines. They either keep posting the same 3/4 suggestions which we’ve all tried or ignore completely the posts like in this case. Such a shame, it’s a beautiful piece of software but if they can’t make it work then there really is no point in using it. I’d even be happy to pay for it, as long as they get more serious about these deal-breaking issues.


#5

It is a shame and makes LBF unsuitable for business use. I understand a paid version is coming out soon, I won’t be buying it unless its under .50p :wink: