Unable to connect to database on any site previously working working without issue


#1

For some reason I’m getting an unable to connect to database errror on every install on local. It was working fine yesterday. Any ideas what may cause this? I’ve tried rebooting.


#2

If you right-click on any site you’re having trouble with then go to Open Site SSH and type service mysql restart what happens?


#3

Error 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysql/mysqld.sock’ (111)


#4

Interesting, that’s the only output after that command?


#5

I rebooted again and got the following error
[ ok ] Stopping MySQL database server: mysqld.
[…] /etc/init.d/mysql: ERROR: The partition with /var/lib/mysql is too full! [FA failed!


#6

I am seeing the same issue, any word on potential fix?


#7

I tried deleting a few installs from my Local install (wondering if it would free up some space ) and no luck


#8

Any update on this issue @clay? All my sites suddenly stopped working with this error :frowning:


Stop working on mac?
#9

Hey all,

I’ve created a gist to help out with this: https://gist.github.com/claygriffiths/fd270f45d82da6feefd723c4fce5a4d7

You can download and run this shell script (it will resize it from 20G to 50G). You may need to change VM_NAME to pressmatic if you used Pressmatic previously.

After you execute the script you must follow the steps starting after to take advantage of the new size. # Install GParted on your boot2docker vm:

If anyone gets stuck please let me know.


WordPress Installation Fails and can't connect to Database
Error Establishing Database Connections
Stuck on Provisioning (Installing WordPress)
Critical error when stopping a site, now Local has completely stopped working
#10

Hi Clay!

Thanks for the script! After some time I’ve deleted Virtual box from my Mac and when restarting Local it installed it again. After that the sites were working again.

Maybe it’s just a coincidence but I though others may try this too.


#11

This is what happened when I tried.

‘service’ is not recognized as an internal or external command,
operable program or batch file.