Regenerating Machine Certificates [Solved for macOS]


#1

Using Local by Flywheel 3.0.4 with Virtualbox Version 5.2.26 r128414 (Qt5.6.3) on macOS 10.12.6. I have 16GBytes of RAM (roughly half of it free), plenty of disk space.

Like many people, I’m now seeing the error message about generating TLS certificates.

What’s weird is that it used to work for me. Here’s the chronology:

I installed Local by Flywheel in November 2018, and it worked flawlessly. I created a few sites, horsed around, tried plugins, etc. It was great - my last successful use was on 6Dec2018.

Holidays ensued, other work intervened. Today, I went to fire up Local by Flywheel, and I started to see the messages about TLS certificates. So I did the following, without any good effect:

  • I removed all (three) local sites to see if one of them was corrupted. (I am not worried - they’re dev servers that all have backups of the production server.)
  • I stopped and removed the local-by-flywheel instance in VirtualBox
  • I trashed, downloaded, and manually installed a new copy of Local by Flywheel (now 3.0.4 - I don’t know what version I had previously)
  • I removed settings at ~/Library/Application Support/Local by Flywheel
  • I installed a new version of VirtualBox (now 5.2.26 r128414, I don’t know what version I had previously)

No joy - I’m still seeing those TLS Certificate messages. I put the logfile into pastebin at https://pastebin.com/2WNegcCy It shows three “consecutive” sessions:

  • 20 November 2018 - working fine, I shut the machine down.
  • 6 December 2018 - started up and it worked fine and I shut it down
  • 29 Jan 2019 (today) - started up and it failed with the TLS Certificate Errors

What other information could I provide to troubleshoot this? Thanks.


#2

I am delighted to say that the procedure linked below worked for me on my macOS laptop. (Follow the first link below to see the full procedure…)

I have documented this in my blog and also added a pointer to the solution into several of the other recent reports in the forum.

@ben.turner @clay - since this appears to happen frequently, could you find a way to:

  1. Document the problem and solution more clearly, so that people searching for it can find a definitive answer.
  2. Look for a way that Local by Flywheel can detect this situation and correct itself?

Thanks.


Local won't start - "Regenerating Docker Machine TLS Certificates"
Checking System / Regenerating Docker Machine TLS Certificates
Regenerating Machine Certificate
Regenerating Docker Machine TLS Certificate, checking system won't start
Local Stuck in endless Loop on Mac OSX - regenerate certificates
#3

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.


#4

Hey @richb-hanover – I’m glad you got it working, and thanks for taking the time to write this up!

We’re always trying to make Local even better, so I’ll pass along this feedback and see if we can’t make this more user-friendly!

– Ben