Local crawling to a halt - Mac Book PRO - Windows 10


#1

First off. Love FlyWheel Local. Nothing like it.

At first it used to run fast. Now it sometimes takes 30 second to 1min seconds to load a page. I have about 20 sites built but am only running 1-2 at a time. I have the latest VirtualBox and am running two cores.

I used to run XAMPP, I like this setup a lot better, but the speeds are really cutting into development time. Anytime I turn on Faster Docker Volumes it automatically turns them off a minute later. I’ve added the exception to Windows Defender on both private and public levels, and disabled Avast for the hour of my testing. No luck getting the change to stick.

Windows 10 on Mac Book PRO
VirtualBox 6
Base memory 10551 (since reduced)
Processors 2

I would do anything to get this working faster. I don’t want to go back to XAMPP. I’d pay a yearly low fee for something that was super fast.

I am running AVAST, but temporarily disabling it doesn’t increase speeds.

Tried changing from NGINX to Apache but the PHP does not render. Just shows the code. Had to change back.


#2

I have the same issue running on MacOS X High Sierra. About 20-30 seconds for most page loads. Seriously?

LbF 2.4.5 (too many issues with v3.x)
MBP 3.2GHz i7, 16 GB
Running only one site at a time.
After Starting the site in LbF, it takes over a minute for the first page to come up.


#3

I managed to speed my instances back up.

I used Avast’s ‘These apps are slowing down your computer’ list and deleted everything I did not need.

I uninstalled all unused programs. I should of kept a list of what I uninstalled but did not.

These are my VirtualBox settings now:

I’m really thinking that unused background services/applications were the real culprit.

Speeds are now back to usable. Just a normal slow(ish) WP site.