Can't Install Local MacOS 3.0.2


#1

Logs above:

Process: Local by Flywheel [5946]
Path: /Applications/Local by Flywheel.app/Contents/MacOS/Local by Flywheel
Identifier: com.getflywheel.local
Version: 3.0.2 (3.0.2)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Local by Flywheel [5946]
User ID: 501

Date/Time: 2019-01-09 12:11:47.468 -0200
OS Version: Mac OS X 10.14.2 (18C54)
Report Version: 12
Anonymous UUID: 811BE8C6-8960-1CD8-3367-D0FCAFBA3CB1

Sleep/Wake UUID: F3DC552D-295C-465D-B57A-58D87558E9CC

Time Awake Since Boot: 16000 seconds
Time Since Wake: 1800 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/Electron Framework.framework/Electron Framework
Referenced from: /Applications/Local by Flywheel.app/Contents/MacOS/Local by Flywheel
Reason: no suitable image found. Did find:
/Applications/Local by Flywheel.app/Contents/MacOS/…/Frameworks/Electron Framework.framework/Electron Framework: file too short
/Applications/Local by Flywheel.app/Contents/MacOS/…/Frameworks/Electron Framework.framework/Electron Framework: stat() failed with errno=1

Binary Images:
0x10d15d000 - 0x10d15dff7 +com.getflywheel.local (3.0.2 - 3.0.2) <81ECE029-ACAE-3254-B3E8-ACC9610CFAB3> /Applications/Local by Flywheel.app/Contents/MacOS/Local by Flywheel
0x111195000 - 0x111213a67 dyld (640.2) <289AB27E-F09F-3384-A14A-100431139559> /usr/lib/dyld

Model: MacBookPro11,2, BootROM 149.0.0.0.0, 4 processors, Intel Core i7, 2 GHz, 8 GB, SMC 2.18f15
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533641465238412D50422020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533641465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x134), Broadcom BCM43xx 1.0 (7.77.61.1 AirPortDriverBrcmNIC-1305.2)
Bluetooth: Version 6.0.9f2, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0256F, 251 GB
USB Device: USB 3.0 Bus
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB OPTICAL MOUSE
Thunderbolt Bus: MacBook Pro, Apple Inc., 17.1


#2

Did you ever get an answer to this? I seem to have the same issue


#3

@coreyallen
No… local is stil not working here :frowning:


#4

I’m sorry you had these troubles with Local. I’d recommend you try to manually re-install it. You can find instructions on doing that here: How do I manually upgrade Local? (similar process for upgrade).

If the issue persists, could you post the log file as a result? That will help us further diagnose the troubles you are having.


#5

@NitantSoni works after force the replace.

It’s weird because I delete and install a fresh one and didn’t work